[Config設定例] Ciscoルーターを用いて、上流拠点とGREを用いてピアを張る場合。

免責事項

本設定例を利用し生じたいかなく損害についても、当団体は一切保証いたしかねます。
下記コンフィグはあくまで設定例です。各環境やセキュリティについて十分配慮したうえで、ご自身で設定されることをお勧めします。

 

設定概要

VIX(上流側) POP(利用者側)
フレッツ・光 NGN終端アドレス またはそのほかのIPv6アドレス 2001:db8:1::1 2001:db8:2::1
GREトンネル内IPv4アドレス 192.0.2.30/31 192.0.2.31/31
GREトンネル内IPv6アドレス 2001:db8:2::1/64 2001:db8:2::2/64
割り当てIPv4アドレス なし 198.51.100.0/28
割り当てIPv6アドレス なし 2001:db8:5::/56
AS番号 65500 65501

 

 

 

 

 

 

 

 

 

 

 

※フレッツ・光サービスは、光電話未契約の場合の設定例です。(RAによりアドレス配布が行われる想定。)

設定例

!IPv6を有効にします。
!
ipv6 unicast-routing
ipv6 cef
!
!GRE over IPv6のトンネル設定を行います。
!
interface Tunnel0
 description TESTGRETUNNEL
 ip address 192.0.2.31 255.255.255.254
 ipv6 address 2001:db8:2::2/64
 ipv6 nd ra suppress all
 tunnel source GigabitEthernet0/1
 tunnel mode gre ipv6
 tunnel destination 2001:db8:1::1
!
!NGN側よりRAによりアドレス取得を行う設定です。
!ひかり電話がある場合は、DHCPv6/PD等でアドレス取得を行う設定が必要です。
!
interface GigabitEthernet0/0
 description NGN-RA
 ipv6 address autoconfig default
 ipv6 enable
!
!割り当てられたアドレスを設定します。このインターフェースからインターネット接続できます。
!DHCPやNAT等を利用する場合は、個別に設定が必要です。
!
interface GigabitEthernet0/1
 description Internet
 ip address 198.51.100.1 255.255.255.240
 ipv6 address 2001:db8:5::1/56
 ipv6 nd ra suppress all
!
!BGPピアを張る設定です。
!割り当てられたASNのうち、いずれかを使用します。
!
router bgp 65501
!
!ルーターIDには、割り当てられたアドレスまたは、トンネル内アドレスを利用することで重複を防ぎます。
!
bgp router-id 192.0.2.31
bgp log-neighbor-changes
!
!ピアの設定を行います。
!
 neighbor 192.0.2.30 remote-as 65500
 neighbor 2001:db8:2::1 remote-as 65500
!
 address-family ipv4
  bgp dampening 10 3000 6000 25
  network 198.51.100.0 mask 255.255.255.240
  neighbor 192.0.2.30 activete
  !
  !MP-BGPは使用しないことが推奨されます。(対向と要相談)
  !
  no neighbor 2001:db8:2::1 activate
 exit-address-family
!
 address-family ipv6
  bgp dampening 10 3000 6000 25
  network 2001:db8:5::/56
  neighbor 2001:db8:2::1 activate
 exit-address-family